Back to overview
Downtime
Hiro app unavailable
May 25, 2026 at 12:42am UTC
Affected services
Hiro App (app.ourhiro.io)
Resolved
May 25, 2026 at 12:44am UTC
We identified a momentary connectivity interruption affecting our Azure database infrastructure.
Connectivity has been restored and Hiro is operating normally again. We are continuing to monitor closely and will complete a root cause review.
We apologise for the inconvenience.
Affected services
Created
May 25, 2026 at 12:42am UTC
We are aware of issues accessing the Hiro app with timeouts and reports "Hiro is temporarily unavailable".
We are investigating this issue with urgency.
Affected services