Back to overview
Downtime

Unable to access Hiro app

Aug 11 at 02:56pm AEST
Affected services
Hiro App (app.ourhiro.io)

Resolved
Aug 11 at 02:58pm AEST

Access to Hiro has been restored.

Created
Aug 11 at 02:56pm AEST

We are aware of issues accessing the Hiro app and are investigating with urgency.